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Foreword 
In this tutorial, we provide various case studies, which are from easy to difficult and combine theory with 
practice. We hope to improve users’ 3D CAD/CAM skills and techniques with ZW3D. 

  

The tutorial bases on our technical engineers’ years of experience in the industry and ZW3D, which is the 
fruit of a lot of efforts and wisdom. We sincerely hope that the tutorial will do help to you, and your precious 
advice on it is highly welcomed.  

 

There are three series for this tutorial: Primary Tutorial, From Entry to Master Tutorial, and Advanced 
Tutorial. From easy to difficult, they offer a step-by-step learning process that can meet different user needs.  

 

Primary Tutorial series is for users who have little or no prior 3D CAD/CAM experience. If you are green hands 
of 3D CAD/CAM software, or if you are a new user of ZW3D, we recommend that you get started with this 
tutorial. Here you can learn the basic knowledge and concepts of ZW3D, rapidly master the simple operations 
and workflows of ZW3D, and practice simple cases.  

 

From Entry to Master Tutorial series is for users with basic know-how of 3D CAD/CAM software. If you have 
experience in 3D CAD/CAM software and want to master common functions of ZW3D, we suggest that you 
start with this series. Here you can dig deeper into the functions and master more operations of ZW3D. 

 

Advanced Tutorial series is for users with practical experience in 3D CAD/CAM software. If you hope to have 
a comprehensive command of ZW3D and get the complicated operations done independently, you can 
choose to learn this series. Here you can learn to use the software more flexibly and get rich experience to 
increase your efficiency.  

 

What you are learning is ZW3D From Entry to Master Point Cloud, a master tutorial.  

 

Thanks for being our user! 

The ZW3D Team 
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1 Point Cloud 

Point Cloud module provides point cloud/STL model import, point block and STL mesh edit, surface rebuild 
functions to assist users convert point cloud or STL data to a surface geometry. 

 

Key Points: 

 Data import  
 Point cloud block edit  
 STL mesh edit 
 Surface/Solid rebuild 

 

1.1 Data Import 

ZW3D supports to import Point cloud data, STL model, OBJ data into modeling level for the next operating.  

1.1.1 Import Point Cloud Data 

Point Cloud Ribbon Tab->Import->From File 

Using this command, user can import the point cloud data from other systems. The point file will be imported 
base on the default part unit.  

Support format: .txt, .asc, .csv, .dat, .exp, .pts, .xyz 

File: Use to specify the point clouds file path. A file browser will pop-up automatically to assist you locate 
where the point cloud file is. ZW3D also allow user input the file path directly. 

Tips: Click  button behind the input box will pop-up a file browser.  

Create Point Bolck: Create a point block to store the point data which is a more compact form for storing 
the point data. And it will lead in accelerating the operation speed. 

 

 Import point cloud data 

Name: Specify which group of the points to import. If here specified by the group name, only specified point 
group will be imported. This option defaults to be empty, thus all the point data in the file will be imported. 
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 Specify group to import 

Reduce Point Set: Check this option to reduce the number of points according to the tolerance. The Manual 
method enables you to set the tolerance for removing points. The tolerancee of Automatic method is 
determined by ZW3D. 

1.1.2 Import OBJ File 

ZW3D supports to import OBJ format which including color and texture. Use import obj command we can 
control whether import color and texture from the OBJ file. 

 

 Import OBJ file 

1.2 Point Cloud Block Edit 

1.2.1 Create a 3D Point Cloud Block 

Point Cloud Ribbon Tab->Edit Block->Group 

Use this command to create a point block to store point data which is a more compact form for storing the 
point data and get a better system performance. We also can use this command to convert a STL model 
become a point block. 

 

 Group 

Points: Specify the points to be grouped as a point block or specify a STL model to convert to a point block. 

Delete Input Points: Check this option to delete the original points. 
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Reduce Point Set: The same function with From file command. 

 

 Create a point block 

 

 Convert STL model to a point block 

1.2.2 Explode a 3D Point Cloud Block 

Point Cloud Ribbon Tab->Edit Block->Explode 

Use this command to explode one or more point blocks to independent points again. 

1.2.3 Trim/Split Point Block 

ZW3D provides several methods for users to trim or split 3D point block/ STL model. User can utilize sphere, 
rectangle box, spline and plane to trim or split the 3D point block. 

1)  Remove Sphere/Box 

Point Cloud Ribbon Tab->Edit Block->Remove Sphere/Remove Box 

Use this command to remove or split a set of points from point blocks by a sphere/ box. 

  

 Remove Sphere 

Center/Boundary/Corner: Specify a point to define the sphere or box. 

Delete Input Points: Check this option to delete the original points. 

2) Remove Polyline 

Point Cloud Ribbon Tab->Edit Block->Remove Polyline 
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Users can define a closed polyline to remove or split a set of points from point blocks.  

  

 Remove Polyline 

Points: Select points to define a closed polyline, then trim or split the point block. 

The polyline plane will parallel to view plane. Thus the trim or split direction will perpendicular to view plane. 
We can rotate the view plane to define a different area to be trimmed or splitted. 

 

  Polyline Plane 

Delete Selected Points: Check this option to delete the original points. 

Inside/Outside: Specify which side points to be deleted when Delete input points option is checked. 

3) Plane Trim/Split 

Point Cloud Ribbon Tab->Edit Block->Trim/Split 

Use this command to trim/split a point block by a datum plane, planar face or a sketch plane 

 

 Trim 

Blocks: Specify point block to be trim 

Trimming: Specify more than one datum plane, planar face or sketch plane to trim the point blocks. If multi 
planes specified, it will use the combined area of planes to trim the point block.  
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 Trim by multi-planes 

1.2.4 Reduce Number of Points 

Point Cloud Ribbon Tab->Edit Block->Reduce 

In order to get a better system performance, we can use this command to reduce the total number of points 
in a point cloud according to specified reduction tolerance. Of course, this operation will cause a lower 
accuracy result. The same as Group function, we can use it to convert a STL model to a point cloud data.  

 

 Reduce  

Points: Specify the points or point blocks to reduce the number. If a STL model is specified, it will convert it 
to point cloud data firstly then reduce the points number.  

✓ Automatic method to reduce points according to an optimization result.  

✓ Manual method to reduce the number of points by specified tolerance parameter.  

In each specified tolerance sized region, only one point will be kept. 

Use Uniformly Spaced Points: Keep all remaining points uniformly spaced apart 

Delete Input Point: Detele the original points or STL model 

Create Point Block: Create a point block for the reduced point cloud 

 

 Reduce number of point cloud 
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1.3 STL Mesh Edit 

1.3.1 Tessellate 

Point Cloud Ribbon Tab->Edit Mesh->Tessellate 

Use this command to traverse all the vertices of specified point block and inter-connect them to form a series 
of triangles, then we can convert a point cloud data to a STL model. ZW3D provide two method (Vertex and 
Uniform Grid) to construct the STL model.  

Vertex: This method leaves the input point data intact, inter-connecting them to build the triangulation faces. 

Uniform Grid: This method builds a grid of uniform facets to fit the point cloud data in each small region, 
then constructs a smooth STL model. The resultant vertices of the triangulation do not necessarily pass 
through the original input points. With dense enough data, the Uniform Grid method will be very close to 
the original set of points. 

 

 Tessellate method 

 

 Tessellate 

Block: Speicfy a point block to construct a STL model. It doesn’t support to construct a STL model with a set 
of individual points, which needs to convert to point block first. 

Method: Speicfy use Vertex or Uniform Grid method to build the STL model. 

Option Assume to no undercut, Resolution, Custom, Smoothness only available for using Uniform Grid 
method to build the STL model: 

Assume no undercuts: If the input point data can be projected along one direction without interfering with 
each other, this option will utilize an optimized Uniform Grid method for much faster results. 

Resolution: Drag to slider to define the triangular facet size from big to small, lead in the grid becomes coarse 
to fine. 

Custom: When the value of Resolution can’t fulfill customer’s requisition. ZW3D allow the user to input a 
custom size of triangular facet to build the STL model. 
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Smooth: Drag the slider to define the connnection of triangular facets from smooth to sharp. 

Fill Remaining Holes: When this option is “ON”, system will automatically fill the hole according to specified 
Max. Edges number. If the number of hole edge is equal or smaller than specified Max Edges number, the 
hole will be patched. Otherwise the hole will not be patched. 

Max. Edges: Specify the number of hole edge utilize to determine the hole to be patched or not. 

 

 Fill remaining holes 

To Keep: After tessellation, there maybe some undesirable facets that formed one or more separated bodies. 
ZW3D can specify a number of STL models to be kept and delete the rest in order to delete undesired facets 
according to the sizes from big to small. 

 

 To Keep 

Delete Input Points: Check on this option will delete the point block which uses to convert to a STL model. 

1.3.2 Triangular Facet Edit 

ZW3D provides several functions to help users to modify triangular facets for the next process. Such as 
add/delete/split facet, reverse the direction of facet, change the common edge between two triangular 
facets. 

1) Add Triangle 

Point Cloud Ribbon Tab->Edit Mesh->Add Triangle 

Use this command to add a new triangular facet by selecting 3 points at STL model. 

 

2)  Fill Hole 

Point Cloud Ribbon Tab->Edit Mesh->Fill Hole 

We can use Add triangle to fill the hole by creating triangular facets one by one. ZW3D also provides another 
more efficient method Fill Hole to help users patch the holes in STL model. Only need to select an edge of 
the hole, then the system will create triangular facets to fill all the holes which are adjacent to the selected 
edge automatically. 
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 Fill hole 

3)  Delete Face 

Point Cloud Ribbon Tab->Edit Mesh->Delete Face 

Select unnecessary facets then click OK button to delete them. 

 

4) Split Edge 

Point Cloud Ribbon Tab->Edit Mesh->Split Edge 

Split one triangular facet to two facets.  

Method: Select an edge of the triangular facet, ZW3D will divide the edge equally then creates two facets to 
divide the original one. If the user selectes a shared edge to split, both triangular facets which have the 
common edge will be split. 

 

 Split edge 

5)  Flip Edge 

Point Cloud Ribbon Tab->Edit Mesh->Flip Edge 

Use this command to flip the edge which is the common edge of two adjacent triangular facets. 

 

 Flip edge 

6) Flip Triangle 

Point Cloud Ribbon Tab->Edit Mesh->Flip Triangle 



Point Cloud 

9 

  

Sometimes the imported STL will have some facets without correct normal direction. This command can help 
us to adjust the normal direction of specified facets.  

1.3.3 Divide Mesh 

Point Cloud Ribbon Tab->Edit Mesh->Divide Mesh 

Use this command can divide selected facets into a new STL block or re-assign the selected facets to other 
STL block. 

 

 Divide Mesh 

Faces: Specify the faces to be divided or be reassigned. 

Create New Mesh: When this option is “ON”, the selected facets will divide from original STL block and create 

a new STL block. 

Add to Existing Mesh: Only when Create new mesh option is OFF, the user can specify selected facets to 
other STL block. 

 

 

 Divide & Reassign STL block 

Tips: Refer to Add to existing mesh, we can combine several unconnected STL models as one. 

1.3.4 Collect Nodes 

Point Cloud Ribbon Tab->Edit Mesh->Collect Nodes 

Use this command the user can collect all the nodes of a STL block within a closed boundary and save as a 
point block. 
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 Collect Nodes 

Block: Specify a STL block to collect nodes (vertices of triangular facets). 

Curves: Specify a closed curve as a boundary to collect nodes. The curve should on the STL block and form a 
closed area of STL block. 

Side: Specify which side of the boundary to collect nodes. It should select a node on the STL to define the 
side. Otherwise the command can’t be executed. 

 

 Boundary for collecting nodes 

1.4 Surface/Solid Rebuild 

ZW3D provides two methods to rebuild a surface or solid from point cloud data or STL model. One method 
is using fit face to convert point cloud data to a surface directory. This method suits for complicated shape 
which is difficult to use modeling method to rebuild. Another method is to create the structure curve firstly 
according to the STL model, then use the modeling method to rebuild a surface or solid. This method is 
suitable for a much regular shape. 

1.4.1 Automatic Method -Fit Face 

Use Fit Face to make a trimmed face that passes through a set of points or a point block. With this approach 
you can divide up an overly complex set of point data into separate sections. Instead of a very large surface, 
several smaller, tangentially connected patches may be generated. This command also supports to create a 
surface with a STL model. 

 

 Fit face with boundary 
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Let’s use an example to see how to use Fit Face to rebuild the surface. 

STEP 01 Use the delete tool to remove the noise points as below: 

 

 Delete noise points 

I. Use Remove Sphere to remove the noise points in top left side. 

 

 Remove noise points with sphere 

II. Use Remove Polyline to remove the noise points in bottom left side. 

 

 Remove noise points with polyline 

III. Use Remove Box to remove the noise points in middle right side. 
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 Remove noise points with Box 

Tips: When the corner point is not easy to pick, we can click the book title mark button to extend the input 
box to adjust the X, Y, Z value independently. 

 

 Adjust X, Y, Z value independently 

STEP 02 Create a plane by offset XZ plane to trim top side of the point block. 

 

 Create a plane 

STEP 03 Trim the point block with the plane in step2. 

 

 Trim with plane 

STEP 04 Trim the right side of point block with YZ plane. (Since there are some holes in the right side. We can 
recover it by mirroring left side of the point block) 
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 Trim by YZ plane 

STEP 05 Mirror the point block with YZ plane. 

 

 Mirror 

STEP 06 Use Group function to combine two pieces of point blocks to be one. 

 

 Combine point blocks 

STEP 07 Reduce the points in point block with 5mm tolerance. 

 

 Draw outline in XY plane 

STEP 08 Use Fit Face to create a reference face with the point block create by step 8. (All options use default 
settings.) 
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 Create a reference face 

STEP 09 Draw the outline in the original point block by Through Point curve in wireframe tab. 

 

 Draw the outline of the point block 

STEP 10 Rebuild the surface with Fit Face. Item Curve C selects the outline create in step 9.  

Select the face create in step 8 as the reference face . Other settings and selection order are below. 

 

 

 Fit face  
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Detail parameters of Fit Face 

Points P: Specify a set of points or a point block to rebuild the surface. The STL model also supports to rebuild 
the surface. Either point block, points or STL model should be an open shape. 

Points Collection: Speicify the point inside a boundary to rebuild a surface. Only when Curves C is specified, 
this option is available.  

Side: Speicfy which side of point cloud data to rebuild a surface. Only when Collect points checked on and a 
Curve C specified, this option is available. 

Normal: Use to redefine the normal of specified Face. 

Curves C: Specify the boundary to rebuild the surface. 

Face: Specify a reference face to rebuild the surface. Point cloud data will project to the specified face and 
according to the face normal, then base on the distance to reference face to rebuild the surface. 

FEM Settings: This command bases on energy minimization to rebuild the surface. Changing the spring 
constant and bending resistance values will affect the rebuilded surface result. 

Tanget at Boundary: Enforce rebuilded surface which is tangent to adjacent surface at a speicfied boundary. 
Only when Curve C specified by edges in face, this option is available. 

U/V Degree: Specify the degree of rebuilded surface. 

Specify Sample Density: When boundary curves are specified, check on this option to specify an averange 
number of sampling points on each boundary curves. 

Sew Shapes: Whether to sew with rebuilded surface. 

Shapes: Specify shapes to sew with rebuilded surface. When this option is empty, all the shapes will be 
sewed. 

Keep Curves: Whether to delete the curves specified in Curves C option. ON to keep, OFF to delete. 

1.4.2 Manual Method 

For some regular or mechanical shapes, using automatic method can’t get a proper result. We may need to 
use the manual method to rebuild the shape. Using manual method to rebuild the shape, firstly we need to 
get the structure curves, then use the modeling method to rebuild it. ZW3D provides several methods to 
help users get the structure curves according to the usage scenarios. 

Notes: Those tools only support to STL model, if there is a point cloud data, you need to convert it to STL 
model first. 

1)  Cross Section 

Point Cloud Ribbon Tab->Create Curve>Cross Section 

Use this command to create the cross intersection curves between a STL model with a plane. 

 

 Cross Section 

STL Model: Specify only one STL model to create intersection curves. 
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Datum: Specify one or several planes or planar face to create intersection curves. 

2) Trace Region 

Point Cloud Ribbon Tab->Create Curve>Trace Region 

Use this command to output the bounding curves of a region on the STL model according to a seed facet 
with limiting angle. After the user specified a seed facet, system will search the facets that the angle of facet 
normal to the seed facet normal below the limiting angle, then adjacent region will be traced and output a 
bounding curves. 

 

 Trace region definition 

 

 Trace region 

Face: Specify a seed facet to define the search area and as a reference to determine the limit angle. 

Limit Angle: Specify an angle to define the search area. 

User Defined Direction: Generally the system will use the normal of seed facet as a reference to define the 
limit angle. When this option is ON, user can specify a new Reference Vector as a reference instead of facet 
normal to define the limit angle. 

3) Trace Sharp Edge 

Point Cloud Ribbon Tab->Create Curve>Trace Sharp Edge 

This command automatically finds out all the sharp edges in an STL mesh, and joins them into NURBS curves 

 

 Trace sharp edge 
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4) Geodesic Path 

Point Cloud Ribbon Tab->Create Curve>Geodesic Path 

Use this command to generate the shortest curve between the 2 picked points on a STL model. Refer to this, 
we can quickly get curves across the STL model. 

 

 Geodesic path 

Notes: 

1) Points selected on different STL model cannot be linked with geodesic path 

2) Only the node of STL can be defined as start point or end point. 

5) Trace Sillouette 

Point Cloud Ribbon Tab->Create Curve>Trace Sihouette 

Use this command to extract the outline of a STL model as 3D silhouette profile according to a specified 
direction of the datum plane. Then we can project these outline to a plane and use it to rebuild the surface.  

 

 Trace silhouette 

STL Model: Specify a STL model to extract the outline 

Datum: System will extract the outline according to the normal direction of a specified datum plane. 

 

 Trace silhouette sample 
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Notes: Then extracted outline will be on the STL model but not on the specified plane. If we want to use the 
outline to rebuild the solid, we need to project the extracted outline to a datum plane first. There is the 
workflow below which rebuild the shape by using Trace Sillhouette. 

 

 Workflow of modeling via trace silhouette sample 

1.4.3 Example of Manual Method 

Here we have a foot STL model. We will use the manual method to rebuild the surface. 

 

 Example of the manual method 

STEP 01 Import the Foot.stl into ZW3D 

STEP 02 Pattern XY plane along –Z direction with 50mm pitch to create 7 more planes 

 

 Pattern XY plane 

STEP 03 Set the bottom plane as a local coordinate system. Then rotate it with 40 degrees along Y axis. 
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 Rotate XY plane 

STEP 04 Pattern YZ plane along X direction with 50mm pitch to create 5 more planes. 

 

 Pattern YZ plane 

STEP 05 Use Cross Section to create section profile with all the planes. 

 

 Create section profiles 

STEP 05 Combine all the wireframe as one and smooth it. Since it has some self-intersection. 
I. Select the Concatenate function in Wireframe Tab 

 

 Concatenate command 

II. Select all the curves in this loop to combine as one 
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 Combine all curves as one 

III. Smooth the curve by FEM Refit command 

 

 Smooth the profile 

STEP 06 Split all the profiles at the intersection point with the curve as below. 

 

 Split the profile 

STEP 07 Split the blue and green curves as below. 

 

 Split curve 

STEP 08 Create the first surface with Curve Mesh in Free Form tab. 
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I. Select the Curve Mesh function 

 

 Curve Mesh 

II. Specify the U curves and V curves as below to create the first surface. 

 

 Create the first face with Curve Mesh 

STEP 09 Split the blue and green curves as below. 

 

 Split curves 

STEP 10 Create the second surface with Curve Mesh in Free From tab. Detailed UV curves settings as below. 

 

 Create the second face with Curve Mesh 

STEP 11 Use Concatenate to combine the bule and green curves. 
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 Combine specified curves 

STEP 12 Split the green curves as below. 

 

 Split curves 

STEP 13 Create the third surface with Curve Mesh command. Detailed UV curves setting as below. 

 

 Create the third surface 

STEP 14 Create the final surface with Curve Mesh command. The green curves set to U curves, the blue curves 
set to V Curves. 

 

 Create the final surface 

STEP 15 Unblank all the surface, then we can see the result as below. 
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 Result 

1.4.4 Surface Fit 

Use this command to analyze the distance between individual points in a point block and a given surface 
that was fitted through the point block. The ratio of a given point distance to the surface and the user 
specified max distance range value determines the color of a point. A perfect fit point will display as green. 
A 1/2 of max range point will display as yellow, and a distance outside the max. Range point will display as 
red. Any value in between will be mapped to the standard linear RGB color gradient of green->yellow->red. 
Customer can have an intuitive image of the rebuilding result with different colors. 

Point Cloud Ribbon Tab->Analyze>Surface Fit 

 

Points: Specify a set of points, a point block or a STL model for analysis. 

Face: Specify a face to compare with the points. 

 

 Surface fit 
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