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Foreword 
In this tutorial, we provide various case studies, which are from easy to difficult and combine theory with 
practice. We hope to improve users’ 3D CAD/CAM skills and techniques with ZW3D. 

  

The tutorial bases on our technical engineers’ years of experience in the industry and ZW3D, which is the 
fruit of a lot of efforts and wisdom. We sincerely hope that the tutorial will do help to you, and your precious 
advice on it is highly welcomed.  

 

There are three series for this tutorial: Primary Tutorial, From Entry to Master Tutorial, and Advanced 
Tutorial. From easy to difficult, they offer a step-by-step learning process that can meet different user needs.  

 

Primary Tutorial series is for users who have little or no prior 3D CAD/CAM experience. If you are green hands 
of 3D CAD/CAM software, or if you are a new user of ZW3D, we recommend that you get started with this 
tutorial. Here you can learn the basic knowledge and concepts of ZW3D, rapidly master the simple operations 
and workflows of ZW3D, and practice simple cases.  

 

From Entry to Master Tutorial series is for users with basic know-how of 3D CAD/CAM software. If you have 
experience in 3D CAD/CAM software and want to master common functions of ZW3D, we suggest that you 
start with this series. Here you can dig deeper into the functions and master more operations of ZW3D. 

 

Advanced Tutorial series is for users with practical experience in 3D CAD/CAM software. If you hope to have 
a comprehensive command of ZW3D and get the complicated operations done independently, you can 
choose to learn this series. Here you can learn to use the software more flexibly and get rich experience to 
increase your efficiency.  

 

What you are learning is ZW3D 2D Drawing, a From Entry to Master tutorial.  

 

Thanks for being our user! 

The ZW3D Team 
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Key Points: 

 Create various views for the parts and assemblies 
 Create/edit the dimensions 
 Add annotations and symbols (Datum, Feature Control Symbol, Surface Finish Symbol) 
 Create text annotations 
 Create a BOM table and the Balloons 

 

1 An Introduction to 2D Sheet  

In the process of product design and manufacturing, a 2D sheet is an important and widely used document, 
although not so visual as a 3D model. 

With a 3D model of the product designed in ZW3D, its associative 2D sheet can be generated. When the 3D 
model is changed, the 2D sheet will be automatically updated.  

1.1 Elements of a 2D Sheet 

Generally, the 2D sheet of a part consists of three parts: 

1 Standard views (Top, Front, Right, Left, Bottom, Back and Isometric), a Projection view, a 
Section view, a Detail view, and so on 

2 Dimensions (Shape dimension & Position dimension), Tolerances (Dimension tolerance, Form 
tolerance & Position tolerance), Datum symbols, Surface finish symbols and Text annotations 

3 Sheet format: Sheet border, Title block, and so on 

Besides, the 2D sheet of an assembly includes different views, assembly dimensions, fit dimensions, a BOM 
table, and so on. 

 

 2D Sheet (Part) 

 

 2D Sheet (Assembly) 

1.2 Create a New 2D Sheet 

Method 1: In the modeling environment, you can insert a new 2D Sheet by clicking 2D Sheet from Document 
Aware Toolbars or the context menu in the working area. Then, select a template to create a new 2D sheet. 
At the same time, the standard view command is automatically activated.  
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 Create a New 2D Sheet—Method 1 

Method 2: Click the New command from the Quick Access Toolbar, then select the Drawing Sheet file type 
and a drawing template. Name the sheet and click the OK button, then a new 2D sheet is created. 

 

 Create a New 2D Sheet—Method 2 

Method 3: Click the New command from the Quick Access Toolbar, then select the Drawing Packet file type 
to create a drawing file. After that, click the + button on the left side to create a new 2D sheet as a file. Other 
operations are like Method 2. 

 

 Create a New 2D Sheet—Method 3 

1.3 Sheet Setting 

➢ Configuration->2D 

You can modify some default parameters of the drawing sheet (shown in the image below). 
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 Configuration 

➢ Tools Ribbon Tab->Setting-> Preferences 

Settings for global drawing sheets, including units, mass units, grid spacing, projection type and 
tolerance. Please refer to Figure 7. 

➢ Sheet Manager->  (on a sheet )-> Attributes 

Set the basic attributes of the selected sheet, such as sheet name, scale, paper color, start label and 
associated model. 

 

 

 

 

 Drawing Settings 

 

 Sheet Attributes 

➢ Sheet Manager->  (on sheet format )-> Sheet Format Attributes 

You can redefine or customize the sheet format according to different requirements. 

 

 Redefine Sheet Format Attributes 

1.4 Customize a 2D Sheet Template 
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Many different 2D Sheet templates are available in ZW3D, such as ANSI, ISO, GB, and DIN. But companies 
may have their templates to meet custom requirements. 

Generally, there are three tasks to customize a 2D Sheet template.  

1) Create a new 2D sheet and set its size. 

2) Define the sheet format, including Sheet border, Title block, and so on. 

3) Define the layer attributes (if necessary). 

4) Define the style attributes (if necessary). 

Task 1: Create a new 2D sheet 

STEP 01 Confirm which template you’re using from Object template file in Configuration->Files. 

 

 Configuration  

STEP 02 Open the 2D drawing template file from File->Templates_MM.Z3, then create a new 2D sheet with 
the default template. 

 

 Create a New 2D Drawing 

Task 2: Define the Sheet Format  

STEP 01 In the Sheet Manager, right-click on Sheet Format, then select Sheet Format Attributes to invoke 
the dialogue box. After that, you can do a series of customizations as follows:        

Sheet Size: Select the standard size or enter the customized values in the Width and Height fields. 

 

 Sheet Size 

Sheet Border: Define the values of the Top, Bottom, Left, Right margins of the Sheet Border and the Partition 
values of Trimming Mark and Centering Mark.  
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 Sheet Border 

Insert Block: Select a standard or predefined block type which is stored in the corresponding template file. 
Or you can just skip this step and do it later. 

  

 Insert Block  

Notes: All 2D sheet template files are in the resource folder of the installation directory. 

 

 2D Drawing Templates 

How to add the customized block (Title Block, Additional List Block, or Code List Block) in the 
template file?  

Here we will take Title Block as an example to show you the steps: 

STEP 01 Open the corresponding template file (Template_Title.Z3). 

STEP 02 Create a new drawing sheet, and name it (for example, “Title block_ZWSOFT”). 
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 Create a New Drawing in the Template 

STEP 03 In the Sheet Manager, right-click on Sheet Format, then click Add Title Block option. Then draw the 
title block in the sketch level. 

 

 Add Title Block 

 

 Draw a Title Block in the Sketch Level 

STEP 04 Link part attributes with the title block using the Text command. 

With the Variable Browser, you can browse all available variables, then select the necessary one to 
embed part attributes in text strings.  

 

 Embed Part Attributes 

STEP 05 After defining the link relationship, you will get the following result. 
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 Title Block in the Sketch Level 

Notes: Some texts might seem overlapped when you are defining the part attributes. But it will not affect 
the results. 

STEP 06 Click the Exit button to return to the 2D sheet, then you will find the completed customized title 
block. 

 

 Customized Title Block 

Task 3: Define the layer attributes 

Click the Layer Manager from the Document Aware Toolbar, then create new layers and set their 
parameters, as shown in the image below.  

 

 Layer Attribute Definition 

Task 4: Define the style attributes 

STEP 01 Click the Style Manager from the Tool Ribbon Tab or Sheet Manager. 
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 Invoking the Style Manager 

STEP 02 Create a new style, for example, linear dimension. Then, set and save the parameters, such as 
Precision and Text Position.  

STEP 03 Double click the new style to make it the default style. 

STEP 04 Save the customized template. 

 

 Create a New Style  

2 Create Views 

2.1 View Layout 

Layout Ribbon Tab->View ->Layout 

This command can help you generate a view layout of a 3D part, where up to 7 views can be created. 

STEP 01 Select the part from a file, then define the views and other parameters, such as Label and Lines 
attributes. 

 

 Define the Layout Parameters 
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STEP 02 The result is shown in the image below. 

 

 View Layout 

2.2 Standard View 

Layout Ribbon Tab->View->Standard 

This command can help you create the standard view of a 3D part. 

STEP 01 Select the part from a file, select a view from the drop-down list, such as Top view, Isometric view, 
then define its location, as shown in the image below. 

 

 Standard View Definition 

STEP 02 Set other parameters, then click OK to get the view. 

  

 Standard View 

General View Attributes 

(1)  : Show Hidden lines/Center lines/Threads 

(2) : Show dimensions from part /Text/3D curves/3D zero point 

If Show dimension is on, then you’ll get the result as shown in the image below.  

 

Notes: Sometimes, the default dimension positions are not optimal. So, it is necessary to adjust them 
manually. 
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 Dimensions from the Part 

(3) Inherit PMI: Check this option to show the available PMI in related views. 

(4) Show scale and Label: Refer to the image below to set the parameters and display attributes. 

 

 The setting of View Scale and Label 

(5) Set line attributes: Set the different line attributes (such as Color, Width, and Layer) for each kind of line. 

(6) Set component visibility: When defining the standard view, you could hide some components or inherit 
the component visibility from part. 

 

 Line Attributes and Component Visibility 

2.3 Projection View 

Layout Ribbon Tab->View->Projection 

Create a view projected from another existing view.  

STEP 01 Select the Base view and define the Location of the projection view. 

STEP 02 Set the Projection (1st or 3rd angle) and Dimension type. 
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 Projection View 

2.4 Auxiliary View 

Layout Ribbon Tab->View->Auxiliary 

Auxiliary view is a projection view that is perpendicular to an edge of another layout view. Normally the edge 
should be oblique. Hence, the horizontal or vertical edge is not suitable as the reference line. 

 

 Auxiliary View 

STEP 01 Select the Base view and select the edge as the reference line.  

STEP 02 Pick a point as the location of the view.  

STEP 03 Set other parameters if necessary, such as the Arrow attribute, as shown in the above image. 

2.5 Full Section View 

Layout Ribbon Tab->View->Full Section 

Use this command to create a variety of section views of a view. 

STEP 01 Select the Base view. 

STEP 02 Pick points to define the position of section.  

Notes: If two points are picked and full section line is through the model, the full section view will be created. 

If more points are picked, the stepped section view will be created. A comparison is shown in Figure 34. 

STEP 03 Select a point as the location of the section view. 

STEP 04 Set other parameters if necessary. 
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 Full Section View and Stepped Section View 

➢ Section Methods 

The Trimmed Part method shows a hidden line view of the entire part cut by the section plane. The Section 
Curves method shows the cross-section only. 

 

 Section View—Section Methods 

➢ Section depth 

After defining the section lines, you can use the Depth option to further clip the model from the final section 
view, then get the preferred section view. This option is available in Full section and 3D named section views. 

 

 Section Depth 

➢ Section Options 

In the Part Attributes dialogue box, the component section and hatch states can be defined, as shown in the 
image below.  
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 Part Attributes 

When creating a section view of the assembly, these attributes can be inherited, as shown in the left image 
of Figure 38. If you want to redefine the component section and hatch states, uncheck the section options 
and right-click on the component, as shown the right image of Figure 38. 

 

 Section Option for an Assembly 

2.6 Aligned Section View 

Layout Ribbon Tab->View->Aligned Section 

This command can help you create a section view in two directions. 

STEP 01 Select the Base view. 

STEP 02 Pick the points to define the section line, including Base points and Align points, as shown in the 
image below. 

 

 Define the Aligned Section Line 

STEP 03 Define the location of the view label and set other parameters if necessary. 
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 Aligned Section View 

2.7 3D Named/Bent Section View 

Layout Ribbon Tab->View->3D Named Section/Bent Section 

This command can help you insert a named section created in the part. The Named Section curve must be 
created with a sketch. 

➢ 3D Named Section command is used for the sketch that consists of lines with zero or more bend 
points at an angle of 90 degrees. The function is similar to the stepped section view. 

STEP 01 Draw a sketch. 

STEP 02 Follow Wireframe Ribbon Tab->Curve->Named Section to create a Named Section curve. 

 

 Create a Named Section  

STEP 03 In the 2D sheet level, use the 3D Named Section command to create the right section view. If Named 
Section curve has been created in the part, then the 3D name option will be activated. The Named 
Section curve can be selected from the list. 

 

 3D Named Section View 

➢ Bent Section command is used for the sketch that consists of lines with bend points at an angle of 
degrees other than 90. The operations of creating a Bent Section view are the same as those of 
creating a 3D Named Section view. 
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 Bent Section View 

2.8 Isometric Section View 

Just like the 3D Named Section command, the section line of the Isometric Section view needs to be defined 
in the part level by following Wireframe->Curves->Named Section. And the sketch line should be open. 

STEP 01 Draw a sketch and create a Named Section curve. 

STEP 02 Use the Isometric Section command to create the needed views, as shown in Figure 44. 

 

 Isometric Section View 

 

 Broken Section View 

2.9 Broken Section 

Layout Ribbon Tab->View->Broken Section 

This command can help you generate the broken section view of an existing view, as Figure 45 above 
shows. 

STEP 01 Select the boundary shape type as circular, rectangle or polyline, and then select the Base view. 

STEP 02 Define the boundary of the Broken section view.  

STEP 03 Define the Depth type and Depth point. 

STEP 04 Define the Depth offset value if necessary. 

➢ Section Plane type: This type is similar to Section View. Select a projected view to be the Depth 
view, then pick a location on that view to be the Depth point for the section. You can also define 
additional Offset points if necessary (Similar to the stepped section view). 
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 Section Plane Type 

➢ 3D Named type: The operations are like those of creating a 3D Named Section. 

➢ Show step lines: If you are using the Section Plane type and select additional Offset points, then 
you can check this option to show the step lines. 

➢ Dynamic hatch scaling and angle: When this option is checked, the hatching scale and angle 
calculated based on the section curves will be used to create the hatch. If unchecked, the value 
entered on the Hatch Attributes Form will be used. 

 

  Dynamic Hatch Scaling and Angle 

2.10 Detail View 

Layout Ribbon Tab->View->Detail 

This command can help you generate a detailed view from other views. 

STEP 01 Select the creation method and Base view. 

STEP 02 Pick the points to define the detail view border.  

STEP 03 Define the view label. 

STEP 04 Set the scale factor of the detail view and define the location of the view. 

 

 

 Detail View 

 

 Crop View 

2.11 Crop View 

Layout Ribbon Tab->View->Crop View 

This command can help you generate a partial view by trimming a view with a defined boundary. 

STEP 01 Select the boundary type. 

STEP 02 Select the view to crop (except detail view, define view, and break line view). 

STEP 03 Define the boundary. 
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2.12 Break Line View 

Layout Ribbon Tab->View->Break Line 

A break line view is suitable for a long cylindrical part, for example, a shaft. The dimension value is 
unchanged. 

 

 Break Line View 

3 Edit Views 

3.1 Edit View Attributes 

You could quickly modify the view attribute with different methods after creating the view. 

Method 1: Context Menu 

Directly right-click on the view or the view name in the Sheet Manager, then select Attribute to edit the 
view attributes. 

 

 Edit the View Attributes from the Context Menu 

Method 2: Layout Ribbon Tab->Edit View->View Attributes 

STEP 01 Choose View Attributes. 

STEP 02 Select the view and middle click to confirm. 

STEP 03 Reset the view attributes in the dialogue box. 

3.2 Edit the View Label or Scale 

Layout Ribbon Tab->Edit View->View Label/View Scale 

Although all the view attributes can be modified with the aforementioned View Attribute, you can edit only 
the view label or scale with some specific edit commands.   

If you need to quickly show or hide the view label or scale, you could right-click on the view or the view name 
in the Sheet Manager, then check or uncheck Display Label or Display Scale. 
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 Display the View Label or Scale 

3.3 Change Part Configurations 

Layout Ribbon Tab->Edit View->Part Config 

This command can help you change the view between different Part Configurations of a 3D part, as shown 
in the below image. 

 

 Part Config 

3.4 Change Component Configurations 

Layout Ribbon Tab->Edit View->Component Config 

This command can help you change the view between default views and exploded views of the assembly. 

 

 Change Component Config 

3.5 Hide Components 

Layout Ribbon Tab->Edit View->Hide Components  

This command can help you hide the components as you need. Actually, it’s a better way to hide the 
components in the View Attribute dialogue box, as shown in the image below. 
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 Hide Components in the View Attributes Dialogue 

3.6 Redefine the View 

After creating the Section View, Detail View or Crop View, you can follow the methods below to redefine 
the view. 

Method 1: Context Menu 

STEP 01 Right-click on the view, then select Redefine to redefine the view. 

 

 Redefine the View 

Method 2: Layout Ribbon Tab->Edit View->Redefine Detail/Redefine Crop View/Redefine Section 

STEP 01 Choose a suitable command from the Edit View panel. 

STEP 02 Select the view to redefine. 

3.7 Edit the Section Line 

If the section view is created with the Full Section command, the section line can be edited after creating a 
view.  

➢ Insert the step points 

STEP 01 Right-click on the section line, then select Insert step. 

STEP 02 Pick a point to insert the step. 

 

 Insert the Step Points 
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STEP 03 Drag and drop the insert point to a suitable position to get a new section line. The projection view 
will be automatically updated. 

 

 Drag and Drop the Insert Point 

➢ Reverse the direction of the section line 

Right-click on the section line, then select Reverse Direction to reverse its direction. The projection view will 
be automatically updated.  

➢ Remove the step point 

Directly drag and drop the step line to align with another, then the two step lines will be merged into one.  

 

 Remove the Step Point 

3.8 Move the View 

By default, not every view can be dragged to any position you want. For example, the Projection View and 
Section View can only be moved along the projection direction. Therefore, if you want to move them to any 
position, please follow the steps below.  

STEP 01 Right-click on the view, then uncheck Alignment.  

Note: Alignment controls the association between the view projection and the Base view. 

STEP 02 Drag and drop the view to any position. 

STEP 03 If you want to regain the original association, check Alignment and move the view again. 

 

 Uncheck Alingment to Move the View 

3.9 Rotate the Base View 

Layout Ribbon Tab->Edit View->Rotate View 

This command can help you rotate the Base view. Select the Base view, then adjust the parameters in the 
pop-up edit toolbar. 

: The view can be rotated by right-clicking when this icon is activated. 

: The view can be moved by dragging the middle mouse button when this icon is activated. 
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 Rotate the Base View 

4 Create Dimensions 

4.1 Set the Dimension Attribute 

It’s a good design habit to set the dimension attribute before creating the dimensions. 

STEP 01 Invoke the Style Manager and edit the dimension style.  

Right-click on the 2D sheet object in the Sheet Manager or directly select Dimension Attribute from 
the Tools Ribbon Tab. 

 

 Dimension Style Manager 

STEP 02 Double-click on a dimension style, for example, a linear one, to set it as currently activate style (or 
create a new dimension style by “New” and set it as the active style). 

STEP 03 Specify the necessary parameters and click the Save button to save the modifications.  

STEP 04 Click the Apply button to apply the activated style. 

 

 Create a New Style and Define the Dimension Style 

 

4.2 Add Basic Dimensions 
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You could create the required dimensions with the quick Dimension tool or other dimension tools. 

  

 Dimension Tools and View with Dimensions 

4.3 Auto Dimension 

 Dimension Ribbon Tab->Dimension->Auto Dimension 

This command can help you create dimensions in batches.  

STEP 01 Select the target view and define a global origin. 

STEP 02 Select the types of entities that you are adding dimensions to. 

STEP 03 Define the placement of the horizontal and vertical dimensions, then click OK to finish. 

 

 Settings of Auto Dimension 

 

 Results of Auto Dimension  

4.4 Linear Dimension Mode 

Dimension Ribbon Tab->Dimension->Linear 

This command can help you create a linear dimension in various ways. 

 

 Linear—Horizontal & Vertical 

 

 Linear—Aligned 
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 Linear—Rotated 

 

 Linear—Projected 

Dimension Ribbon Tab->Dimension->Baseline/Continuous/Ordinate  

This command can help you create a 2D linear baseline/continuous/ordinate dimension group. 

STEP 01 Select the first point and the second point if needed. 

STEP 02 Pick a point to place the dimension text. 

STEP 03 Select other points to define the dimension group. 

Notes: In the following images, the multiple 3 or 4 markers indicate the additional dimension points. 

 

 Baseline 

 

 Continuous 

 

 Ordinate 

4.5 Hole Callout 

Dimension Ribbon Tab->Dimension->Hole Callout 

This command can help you create one or more hole callout dimensions.  

STEP 01 Select the layout view and pick the holes (circle or arc). 

STEP 02 Check the needed hole parameters. 

STEP 03 Click OK to finish. 

 

 Hole Callout Dimensions 

Notes: If you want to create the hole dimensions on the projection view of the hole, please use the Label 
command to manually do it. 
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4.6 Other Dimensions 

Dimension Ribbon Tab->Dimension->Linear Offset/Arc Length/Radial/Angular/Linear 
Chamfer/Symmetry 

  

 Other Dimensions 

5 Edit Dimensions 

5.1 Edit Dimension Attributes 

Method 1: Right-click on the dimension, then select Attributes to edit all dimension attributes, including 
tolerance, dimension line/arrow, text, font, etc. 

 

 Edit Dimension Attributes 

Method 2: Dimension Ribbon Tab->Edit Dimension->Dimension Quick Edit 

This command can help you quickly edit partial dimension attributes, such as dimension tolerance, precision 
and appended text. 

 

 Dimension Quick Edit 

5.2 Quick Dimension Tools 

In ZW3D, quick tools for editing dimensions, including dimension symbol, tolerance and precision are 
available.  

STEP 01 Right-click on the blank area in the Ribbon Tab, then ToolBars and DimTool. 
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 Quick DimTool 

STEP 02 Pick any dimension, then select the command to quickly add a symbol, edit tolerance or change 
precision, as the images below show. 

 

 Add Symbol 

 

 Add Equal Tolerance 

 

 Change precision 

5.3 Add Tolerance 

Method 1: Dimension Ribbon Tab->Edit Dimension->Modify Tolerance 

Method 2: Right-click on the dimension, then select Modify Tolerance to edit. 

 

 Method 2—Unequal Tolerance 

Method 3: Right-click on the blank area in the Ribbon Tab, then ToolBars and DimTool.  

Notes: If you want to add the tolerance zone, just select the Tolerance zone type in the Modify Tolerance 
dialog, then click Inquire tolerance to inquire the tolerance zone. Select the suitable tolerance zone, then 
click OK, as shown in the image below. 
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 Define the Tolerance Zone 

5.4 Toggle Reference Dimension 

Dimension Ribbon Tab->Edit Dimension->Toggle Reference 

This command can help you toggle a dimension to or from the reference dimension. 

 

 Toggle Reference Dimension 

5.5 Edit Dimension Texts 

Method 1: Dimension Ribbon Tab->Edit Dimension->Modify Text  

Method 2: Right-click on the dimension, then select Modify Text to invoke the Dimension Editor, as shown 
in the image below. You can directly input the customized text to replace the system value and add some 
symbols or link the variables to the dimensions. 

 

 Modify Dimension Text 

5.6 Modify Text Point 

Right-click on the dimension or follow Dimension Ribbon Tab->Edit Dimension, you can select Modify Text 
Point to modify the location of the text point of a dimension or change the mode of text placement 
(automatic/manual). The dimension text and extension lines will adapt accordingly. 
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 Modify Text Point 

Notes: A more convenient way to change the location of the text is to drag and drop the dimension text 
based on the defined placement mode. 

5.7 Modify Dimension Points 

This command can help you redefine a dimension. For example, if a dimension becomes invalid, you could 
make it valid again by redefining the dimension point with this command. 

Method 1: Dimension Ribbon Tab->Edit Dimension->Modify Dimension Points 

Method 2: Right-click on the dimension, then select Modify Dimension Points to edit. 

Notes: This quick method to modify the dimension points or the position of texts is highly recommended:  
click the dimension, then drag and drop the control point or text to a new position. 

 

 Modification of Dimension Points 

5.8 Modify Part Dimensions 

When creating a 2D view, invoke the Show dimensions from part option, and a view with part dimensions 
will be created. 

 

 The View with a Part Dimension 

Modifying the value of this kind of part dimensions in the 2D view will drive the part geometry. Meanwhile, 
other views will be updated automatically. 

Method 1: Dimension Ribbon Tab->Edit Dimension->Modify Part Dim 
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Method 2: Right-click on the dimension, then select Modify Part Dimension. 

 

 Modifying a Part Dimension 

5.9 Align Dimensions 

Dimension Ribbon Tab->Edit Dimension->Modify Text Alignment 

This command can help you align one dimension with another. 

Select two dimensions and the first dimension will be aligned with the second one. 

 

 Align the Dimensions 

5.10 Edit Dimension Groups 

Dimension Ribbon Tab->Edit Dimension->Add to Group 

Select a dimension in the group and specify a point to insert the new dimension into this group. 

 

 Add to Group 

Dimension Ribbon Tab->Edit Dimension->Remove from Group 

Select a dimension from a dimension group to remove. 

Dimension Ribbon Tab->Edit Dimension->Explode Group 

This command will turn each dimension of a dimension group into an individual object. 

6 Annotations and Symbols 

6.1 Label Coordinate 
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Dimension Ribbon Tab->Annotation->Label Coordinate 

This command can help you create labels for the coordinate of the points. 

STEP 01 Pick a point as the Origin, then the coordinate of the point will be calculated accordingly. 

STEP 02 Select one or multiple points to create the label. 

 

 Label Coordinate 

➢ Text: You can determine which coordinates will be displayed in the view, as shown in the below 
image. 

 

 Text Settings 

6.2 Label 

Dimension Ribbon Tab->Annotation->Label 

You can manually create a label with this command. The procedures will be illustrated with the example of 
a counter-bore hole. 

STEP 01 Pick one or multiple points to locate the label. 

STEP 02 Input the dimension text in the Dimension Editor dialogue box, as shown in Figure 94 below. 

Click , add hole dimension D1 value(32); then click , add hole depth H1 value (95); line feed; click 

and , add hole dimension D2 value (52), then click , add hole depth H2 value (5). 

 

 Define Dimension Text with 
Editor 

 

 

 Hole Dimension Label 

STEP 03 Click OK and the label will appear, as shown in the image above. 

STEP 04 Use Leader pts to locate additional leader arrows if necessary. 
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6.3 Datum Feature/Target 

Dimension Ribbon Tab->Annotation->Datum Feature 

This command can help you create a datum feature, which can be used in Feature Control Symbol. 

STEP 01 Input the label text or use the default value. 

STEP 02 Select the target entity. 

STEP 03 Pick a point to locate the text. 

STEP 04 Set the display parameters in accordance with the requirements. 

 

 Datum Feature 

Dimension Ribbon Tab->Annotation->Datum Target 

This command can help you establish a datum by creating a datum target (a specific point, line or area on a 
part). 

STEP 01 Determine the type of the Datum Target, which can be a Target point, Target area (circle or 
rectangle) or Target line. 

STEP 02 Determine the position of the Datum Target. 

STEP 03 Define the size of the target area if necessary. 

STEP 04 Define the Text point. 

STEP 05 Define the Datum Text and the Datum Text 2 or Datum Text 3 if necessary. 

 

 Datum Target 

6.4 Feature Control Symbol 

Dimension Ribbon Tab->Annotation->Feature Control 

This command can help you create a feature control symbol. 

STEP 01 Define the FCS text in the Feature Control dialogue box. 

STEP 02 Pick the location points of the FCS text. 

STEP 03 Define other parameters, such as additional Leader Points and the Display type.  
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 Feature Control Symbol 

 

 Defining the Feature Control Symbol  

6.5 Center Mark/Center Line/Center Mark Circle 

Dimension Ribbon Tab->Symbol->Center Mark 

This command can help you create a center mark on an arc or circle, as shown in Figure 100. 

Dimension Ribbon Tab->Symbol->Center Line 

This command can help you create a centerline on a line, arc or circle, as shown in Figure 101. Also, you can 
manually draw a centerline by picking two points. 

➢ Use individual extension 

Check the Use individual extension option. 

 

 

 Center Mark 

 

 Drag and Drop the Center Line 

Dimension Ribbon Tab->Symbol->Center Mark Circle 

This command can help you place centerlines on entities following a circular pattern, for example, a bolt 
hole. 

STEP 01 Select the center points of all holes. 

STEP 02 Set the type of center marks and define other parameters if required. 

 

 Center Mark Circle 

 

 Center Mark Circle—Circular Centerline 

➢ Create as a circular centerline 

Check this option to show the circle instead of the center marks. 
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6.6 Surface Finish Symbol 

Dimension Ribbon Tab->Symbol->Surface Finish 

Surface finish represents the machining quality of part surface. So in the 2D view, it is required that you 
select the edge and define the surface finish symbol. 

STEP 01 Pick a point to locate the symbol. 

STEP 02 Define the angle of orientation or lead point if needed. 

STEP 03 Select the machining type and set the value.  

 

 Surface Finish Symbol 

6.7 Intersection Symbol 

Dimension Ribbon Tab->Symbol->Intersection Symbol 

This command can help you easily add an intersection symbol between 2 entities. 

 

 Intersection Symbol 

6.8 User Symbol Management 

Dimension Ribbon Tab->Symbol->Insert/Add/Manage 

These commands can help you insert a customized symbol from the symbol library. 

➢ Add is used for saving entities to the active symbol library. You can select a part of or the entire 
drawing sheet, define the Base Point and Name, then click OK to finish. 
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 Add Symbol to Library 

Note: By default, the symbol will be restored in the current file. But if you have added a file to the 
Configuration->Files tab->Symbol library, then the symbol will be restored to this file instead, as shown in 
the below image. 

 

 Symbol Library Definition 

➢ Insert is used for inserting symbols from the library to the current sheet. Simply select the file and 
needed symbol, then drag it to the position you want. 

➢ Manage is used for managing the symbols in the library, such as deleting or renaming them. 

7 Table and Balloon 

7.1 Create a BOM Table 

Dimension Ribbon Tab->Table->BOM 

This commands can help you create a BOM table for the selected view (detail or section). 

The image below is an assembly consisting of some components and sub-assemblies. 

 

 Assembly Model 

➢ Level Setting  

Top-level only means that parts and sub-assemblies will be listed, but not the components of the sub-
assemblies. 

Parts only means that all parts (including the ones of all sub-assemblies) will be listed, but not sub-assemblies. 
Each subassembly component is an individual item.  



2D Drawing 

34 

 

 

 Level Setting of BOM 

 

 Top-level only VS. Parts only 

Indented means that all the parts , sub-assemblies and their components will be listed. Also, you can define 
the ID with one of the three types of numbering, as shown in the image below. 

 

 Indented Level 

➢ Max traverse depth 

This option is to define the level of assembly from which the BOM table should read the data. 

When this option is checked and the value is set to 2, you will get the following BOM table. 

 

 

 

 

 Different Traverse Depth 

 

 Item Number and Template 

➢ Table ID Order 

There are 3 different methods to sort the table IDs. 

Order by name: Based on the part name to sort the table IDs. 

Order as assembly: Based on the order of component insertion to sort the table IDs. 

Regenerate IDs after sort: When table order is changed, IDs will be regenerated. The table order is controlled 
by another parameter, as shown in the image below. 
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 Table Order 

Note: If the Sort when regenerating option is unchecked, the order will not change, so IDs also will not change. 

All available part attributes are listed in here, including black-colored system attributes (such as Legend) and 
green-colored user attributes (such as Stock Size), as shown in Figure 113. 

The  icons allow you to add or delete attributes. 

The   icons allow you to rearrange the sequence of the attributes. 

 

 BOM Table 

➢ BOM Filter 

Use BOM Filter to set up some conditions to generate a specified table. Part Attributes and customized 
attributes are available for this filter condition.  

 

 BOM Filter 

7.2 Edit the Table 

As the image below shows, you can click  to invoke the Table dialogue box and click any column or row 
to invoke the Table Column/Row dialogue box. Then you can add or delete columns or rows, set the text 
alignment and text attributes, etc. 
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 Table Editor 

➢ Edit the Column Name  

Double click the column header to edit, such as Material ->Part Material. 

➢ Edit the Column Attributes 

Right-click on the column header, then click Attributes to edit attributes in the Table Attributes dialogue 
box, for example, the value of precision. 

 

 Edit Column Name and Attributes 

➢ Edit Cell Value  

Double-click on the cell, then click Yes to edit. 

 

 Edit Cell Value 

➢ Sync BOM Table with Part Attributes 

Method 1: Right-click on  and then click Sync BOM Table with Part Attributes.  

Method 2: Right-click on the name of the BOM table in the Manager, then click Sync BOM Table with Part 
Attributes. 
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 Sync BOM Table with Part Attributes 

Next, you can check the Part Attributes in the modeling level following Tool Ribbon Tab->Attributes->Part 
Attributes.  

 

 Updated Part Attributes 

➢ Edit Table Header  

Right-click on  ->Insert->Head Row. Then you can merge the cells or edit the header cells. 

 

 Edit Table Header 

➢ Table Template 

Right-click on  ->Save as Template… to save this table header as a BOM template for later use. 
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 Table Template 

➢ Import/Export Table 

The table can be exported with Export Table and saved as an Excel® file for later modification. Then the 

edited Excel® file can be inserted back into the 2D sheet, as shown in Figure 124, 

 

 Import & Insert Table 

7.3 Auto Balloons 

Dimension Ribbon Tab->Annotation->Auto Balloon 

Balloons can be automatically generated in a view based on the visibility of components and inserted into 
the appropriate views without duplicates. You can also specify whether the balloons follow the order of 
assembly or are numbered sequentially.  

STEP 01 Select the 2D view. The default balloon text is ID. 

Notes: The Lower Text option is activated when the balloon type is Circular split line. 

 

 Balloon type-Circular split line 
 

STEP 02 Set the layout parameters. Pattern type is defined as square type. 

STEP 03 Set Balloon type as circular and use the second Quantity type.  

STEP 04 Click OK to get the result, as shown in the image below. 
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 Auto Balloon Result 1 (Pattern type: Square, Balloon type: Circular, Quantity: the 2nd type) 

You could try other combinations of parameters to get different results, as shown in the image below. 

 

 Various Auto Balloon Results 

More Layout Parameters 

If there is a BOM inserted in the drawing sheet, these 2 options are activated. 

 

Only for components in BOM is to control whether the components excluded from the BOM should be 
labeled. If the excluded components are included, a * character will be used as their ID and you can modify 
it.  

Only for items without balloon is to label the components which are not labeled in any other views.  

Below is an example. 

STEP 01 Create the top view and the projection view on the left. 

STEP 02 Create the BOM table with the Part only method.  

STEP 03 Select the top view to create the balloon. 

STEP 04 Select the projection view to create the balloon and set the parameters. 

 

 Definition of Parameters 
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 Balloons 

7.4 Balloons 

Dimension Ribbon Tab->Annotation->Balloon 

This command allows you to manually create a balloon for the picked entity, even with multiple base points 
and leader arrows, as shown in the image below. 

The parameters of dimension attributes are the same as those of Auto Balloon. 

 

 Manual Balloon 

7.5 Stack Balloons 

Dimension Ribbon Tab->Annotation->Stack Balloons 

This command can help you stack multiple ballons together, as shown in the image below.  

 

 Stack Balloons 

7.6 Hole Table 

Dimension Ribbon Tab->Table->Hole 

This command can help you create a hole table based on a layout view that contains real holes and user-
defined holes. The model below is an example. 
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 Hole Model 

STEP 01 Create a top view of the model.  

 

 Top view-Hole 

STEP 02 Select the 2D view and name the hole table. 

STEP 03 Pick a point as the Base point, according to which the x & y coordinates of the hole will be defined 
in the hole table. 

STEP 04 Set the Hole Filter. By default, only front-facing holes are selected. 

STEP 05 Set other parameters if required. For example, check the Combine same size option. 

STEP 06 Click OK. Then pick a point to insert the hole table. 

 

 Hole Table 

➢ Hole Filter 

Backfacing Holes/Hidden Holes 

When only the Backfacing holes option is checked, the back-facing hole features based on this view plane 
are selected. But if the back-facing hole is not a thru-hole, it will not be selected. 

When both the Backfacing holes and Hidden holes options are checked, all back-facing holes will be selected. 

Boolean Holes 

If this option is checked, the imported holes and Boolean holes will be included. 
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Notes: Checking or unchecking these three options does not affect holes that you have already selected for 
the hole table. Also, this option is ineffective when you’re selecting user-defined holes. 

Hence, please redefine the View option after resetting the hole filter. Then the selected hole features will be 
updated, as shown in the image below. 

 

 Reset Hole Filter 

How to add the user-defined hole into the hole table?   

STEP 01 If some circles are drawn in the part level, you can edit the View Attributes to show them first. Right-
click on the view->Display others->Show 3D Curves from Part.  

In the image below, there are two circles. Circle 2 is concentric with one of the hole features. 

 

 Show 3D Curves from Part 

STEP 02 Activate the User-defined option, and Circle 1 can be picked. If you want to pick Circle 2, the User-
defined centered on feature option should be checked. 

 

 User-defined Hole Feature 

STEP 03 Pick all hole features and add user-defined holes for the hole table.  
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 The Whole Hole Table 

7.7 Annotation Table 

Layout Ribbon Tab->Table->Annotation 

This command allows you to generate Point Table or Dimension Table. 

➢ Point Table  

STEP 01 Select the needed points for the Point list and define one as the Base point. 

STEP 02 Name the Point Table. 

STEP 03 Select the available attributes for the columns of the table.  

 

 Point Table 

➢ Dimension Table 

The operation is similar to that of Point Table. You can get the result by following the 3 steps in the image 
below. 

 

 Dimension Table 

8 Auto Drafting 

Part/Assembly context->Tools Ribbon Tab->Insert->Auto Drafting 
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Auto Drafting can generate a drawing sheet automatically for the selected assemblies, components or 
shapes at once to improve your work efficiency. 

STEP 01 Select the models to draft. 

STEP 02 Define the size and saving path of the sheet, and its name and scale if necessary. 

STEP 03 Define the layout of the sheet, as how you’d use the Layout command in the 2D sheet level. 

 

 Steps of Auto Drafting 

STEP 04 Define the settings of Auto Dimension and Table if necessary, then you’ll get multiple sheets all at 
once. 

 

 Auto Drafting Results 

The aforementioned steps are just the basic way to use Auto Drafting in ZW3D. Let’s see how to use other 
options to meet your different needs. 

 

3D Model Selection Settings 

There are 3 methods to select models to create a drawing sheet in ZW3D: By Layers, By Filters and Pick from 
graphic.  

➢ Auto Selection-By Layers 

You can pick layers to determine the objects that will be generated in the drawing sheet. After you picked 
the layers from the layer list, you can keep picking the objects from the object list for the drawing sheet.  
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 By Layers 

 

 By Filters 

➢ Auto Selection-By Filter 

You can filter out objects to create a drawing sheet. The standard attributes can be used as a filter, such as 
a name, designer, cost, etc. And you can keep picking the objects from the object list for the drawing sheet.  

Besides, the defined condition can be saved as a template for future use. Click the  button, input a name 
and click OK, then the new filter will be saved as a template file. 

 

 Filter Template 

 

 Pick from graphic 

➢ Manual Selection- Pick from graphic area 

You can pick objects in the graphic area manually to create a drawing sheet, as shown in Figure 146. 

Besides, 2 more options are provided to control whether to create the drawing sheets for shapes or the top-
assembly.  

1) Include Shapes:  

      When there are shapes in the current assembly level, the shapes are available to create the drawing 
sheets. 

2) Include current object:  

      The top-assembly of the current level is available to create the drawing sheets. 



2D Drawing 

46 

 

 

 Check “Include shapes” 

 

 Check “Include current object” 

Set Sheet Attributes 

In the Sheet Tab, you can specify the name, template, size and save type of the sheet. 

➢ Types to Save the Drawing Sheet 

1) All in one drawing: All sheets will be saved into one drafting object. 

2) One object for each: All sheets will be saved in different drafting objects but one Z3 file. 

3) One file for each: All sheets will be saved as different Z3 files. 

➢ Sheet Template Settings 

The default template of Auto drafting will be the template set in Configuration. But, you can also specify an 
external template to be the new drawing sheet. When the template file is specified, all the Sheet Size in 
sheet templates and sheet sizes will be read for you to specify the sheet size of different objects. 

➢ Sheet Name Setup 

The name of each drawing sheet can be generated according to the rule defined by Prefix, Variation or Suffix.  

The Prefix and Suffix fields can define by 4 types of attributes: 

1) Name of the object to draft: The reference format is [$Object name]. 

2) Number of the object to draft: The reference format is [$Number]. 

3) Sheet Code of the object to draft: The reference format is [$Sheet code]. 

4) Root assembly name: The reference format is [$Assembly name]. 

The “Variation” field is used to define the increment method of sheet name. 

 

 Sheet Name Setup 
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Notes: After finishing setting up Prefix, Variation and Suffix, you can click Update picked item to update the 
sheet name preview in the dialog. 

➢ Custom Coordinate and Origin  

View projection can have various results based on different frames. By default, Auto Drafting use the WCS 
(World Coordinate System) as the projection coordinate system. If you want to redefine a coordinate system 
to create a drawing sheet, pick the redefined items first, then click Custom coordinate and origin to invoke 
a dialogue box to define. 

 

 Frame and Origin Setting for View Projection 

Notes: The Auto dimension is supported by Auto Drafting. Therefore, the default origin will be used to create 
dimensions. You can use the Custom coordinate and origin to redefine the origin. 

 
Set View Attributes 

Please refer to Chapter 2.1 for procedures of setting view attributes. 

 

 View Projection Settings 

Auto Dimension Settings 

Please specify the type of views and objects to generate the dimensions. In the Dimension tab, you can 
specify the view where you’re creating dimensions with auto dimension, and the entities to create the 
dimensions and type of dimensions as well. 

➢ Enable Auto Dimension  

Check this option and other settings in this tab will be available. Otherwise, you will not be able to generate 
any dimension in the drawing sheet. 

➢ Layout 

Specify the views you’re adding the dimensions to. Only the views enabled in the View Tab can be selected 
to create dimensions. 
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 Views for Auto Dimension 

➢ Entities to dimension 

You can specify the detailed settings of Auto Dimension. For more details, please refer to Chapter 1.4.3. 

 

 Auto Dimension Settings 

Table Settings  

BOM and hole tables can be generated during the Auto Drafting process. Also, the BOM table will be 
generated in each assembly drawing sheet. The location, template and other settings can be saved to the 
template.   

❖ BOM Table Settings 

➢ Enable BOM table 

Check this option to enable the creation of BOM tables and other settings for the BOM table. 

➢ Location 

The location of the BOM is defined by its origin and the position of the origin in the drawing sheet 
(represented by the percentage of the sheet size). 

➢ Table origin 

 

 Table Origin 

➢ Sheet origin and percentage division 
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 Sheet Origin and Percentage Division 

For example, if the location has been set to Top-Right and 100%,100% at the same time, the table will be 
located as the image below shows: 

 

 Table Location Definition 

➢ Template  

You can specify an external BOM table template. 

➢ Level setting  

You can choose from the 3 output types of BOM: Top-level only, Parts only or Indented. Then, check the 
Include shapes option to integrate shape items into the BOM table. You can refer to Chapter 7.1 for more 
information. 

➢ Auto balloon 

Check this option so that balloons will be added to the main view automatically. 

 

 BOM Table Settings 

 

 Hole Table Settings 

❖ Hole Table Settings 

Setting a hole table is mostly similar to setting of BOM table, except that you can determine whether the 
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back-facing holes, hidden holes and Boolean holes will be displayed in the hole table, as Figure 159 shows. 

The current settings can be saved as a template for future use. Click the  button, then name the 
template. 

 

 Table setting template 

9 Case—2D Drawing 

 

 The 3D Model 

STEP 01 In the modeling level, select the 2D Sheet command and the A2_H (ANSI) template to create a 2D 
sheet. 

STEP 02 Create a standard top view, as shown in the image below. 

 

 Top View 

STEP 03 Use the Full Section command to create two section views. The parameters are set as the image 
below shows. 

 

 Section Views 

STEP 04 Drag and drop the endpoints of the section line to get a better position. And right-click on the 
section line to select the Display label command. 
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 Section Views with Labels 

STEP 05 Use the Broken Section command to create two broken section views on top view. 

 

 Broken Section Views 

STEP 06 Invoke the Style Manager to modify the value of precision of the linear dimension, the text format 
of the chamfer dimension, the text shape, etc. 

 

 Dimension Style 

STEP 07 Create the dimensions, annotations, hole labels, surface finish symbols and so on. 

 

 View with Dimensions 

STEP 08 Set the default drawing units. Tool Ribbon Tab->Setting->Preference 
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 Drawing Settings 

STEP 09 Edit the title block. You could add some part attributes with the Text command or in the editor. 

 

 Edit the Title Block 

Notes: Some texts might seem overlapped when you are defining the part attributes. But it will not affect 
the results. 

STEP 10 After editing, go back to the 2D drawing level, and you will find all the information linked with the 
part attributes. 

 

 Title Block 

STEP 11 Add some technical requirements with the Text command. 

STEP 12 The final 2D sheet should be how the image below shows. 

 

 2D Sheet of Part 
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